tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bilal Ahmed" <bah...@formtek.com>
Subject RE: Tomcat not showing pages-----
Date Tue, 30 Sep 2003 01:54:34 GMT
Hi Sat

Try cleaning up the cache in the work directory.  Maybe that will help?  I
have seen this problem multiple times where once a JSP page is compiled, it
won't compile again till you remove the cache.  Just remove all the
files/directories within the work directory.  Usually Standalone directory
is there and has to be deleted.

Bilal

-----Original Message-----
From: kgsat [mailto:kgsathiyam@kssnet.co.jp]
Sent: Monday, September 29, 2003 6:21 PM
To: tomcat-user@jakarta.apache.org
Subject: Tomcat not showing pages-----


Hi

I am running the tomcat version 4.1.24 for my web application.
When i start the tomcat it gets started well with the usual prompt messages.
But when i try to access the example directory or any sample pages, it does
not show the jsp or html pages at all.The IE window comes out to be empty
and i am not getting any error or exception in the server prompt.

On further analysis, it has been revealed that catalina log gives the
following error messages.

****************************************************

2003-09-26 10:33:28 CoyoteAdapter An exception or error occurred in the
container during the request processing
java.lang.NoSuchMethodError:
javax.servlet.http.HttpServletRequest.getUserPrincipal()Ljava/security/Princ
ipal;
 at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase
.java:455)
 at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
eNext(StandardPipeline.java:641)
 at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
 at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
 at
org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2416)
 at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180
)
 at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
eNext(StandardPipeline.java:643)
 at
org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.
java:171)
 at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
eNext(StandardPipeline.java:641)
 at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:172
)
 at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
eNext(StandardPipeline.java:641)
 at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
 at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
 at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java
:174)
 at
org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invok
eNext(StandardPipeline.java:643)
 at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
 at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
 at org.apache.coyote.tomcat4.CoyoteAdapter.service(CoyoteAdapter.java:223)
 at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:601)
 at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConne
ction(Http11Protocol.java:392)
 at
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:565)
 at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:619)
 at java.lang.Thread.run(Thread.java:536)

****************************************************

What i am confused with is , i was getting the tomcat running and showing
the pages properly until i changed from version 4.1.24 to 4.1.27,which
happens to be stable one.
Now even when i reverted back to the same version, i could not run the
tomcat to show the pages as earlier.
Does any body know what would be wrong with my tomcat?
Any help is highly appreciatedd!!!
thanks
sat


Mime
View raw message