tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From barkingm...@freenet.de
Subject deployment problems
Date Fri, 12 Sep 2003 09:05:03 GMT
hello,
i have just completed a course on web programming where all the practical work was done on
a windows box. now i try to redo everything on my linux (suse 8.2) machine and i keep hitting
problems. i have checkeed the archive for "deployment" and if the right clue is there i didnt
identify it hence this:

situation:
==========
* installed are jdk1.4.x and tomcat 4.1.x as out of the box.
* i have taken the sample webapp we developed during the course and put it (the whole subdir,
that is: classfiles, jsp, html, web.xml) in the webapps subdir.
* i have created a context entry through the admin application that all but copies the examples
entry.
* pointing browser to <http://localhost:8080/MyApp/myappstart.jsp> does produce the
desired result, however any furher activity - like clicking a login button - produces a <404
resource package.Classname not available> response. Yet the class files are where they
supposedly belong.

try/fails
=========
* calling class files directly via .../servlet/...: same result
* chown-ing my stuff to the owner of Tomcat/webapps/examples: no difference

i am out of ideas. any help appreciated.

thanks and all, mats





-- 
eBay - Jetzt besser einkaufen!
Ueber 1. Mio. Angebote. Startpreise ab EUR 1,-
http://www.freenet.de/tipp/shopping/ebay
Mime
View raw message