tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wilson, Allen" <Allen.Wil...@marcresearch.com>
Subject RE: Configuring and using cgi scripts in Tomcat
Date Tue, 23 Sep 2003 20:35:01 GMT
Okay...

I think I have the mapping correct because it now finds the file but
tries to download it. I am trying to add a listing to the mime type so
that it will process the file as a script.

I added the following entry to the mime types mappings list

    <mime-mapping>
        <extension>cgi</extension>
        <mime-type>application/x-httpd-cgi</mime-type>
    </mime-mapping>

But it stills tries to download the file. Does anyone know of another
mime list for CGI Scripts

Allen

-----Original Message-----
From: Jon Wingfield [mailto:jon.wingfield@mkodo.com] 
Sent: Tuesday, September 23, 2003 12:47 PM
To: Tomcat Users List
Subject: Re: Configuring and using cgi scripts in Tomcat


/resporta/cgi-bin/animal.cgi does not map to /cgi-bin/*

I'm guessing "resporta" is the name of your webapp?
Where did you place the script? As I read it, you need to put it in 
/ROOT/WEB-INF/cgi (I could be wrong).

HTH,

Jon

Wilson, Allen wrote:

> Okay....
> 
> I did all that....
> 
> 1 - Uncommented the lines for the <servlet> container
> 2 - Uncommented the lines for the <servlet-mapping>
> 3 - renamed the servlets-cgi.renametojar file to servlets-cgi.jar
> 
> Here are those listings:
> 
>     <servlet>
>         <servlet-name>cgi</servlet-name>
>  
> <servlet-class>org.apache.catalina.servlets.CGIServlet</servlet-class>
>         <init-param>
>           <param-name>clientInputTimeout</param-name>
>           <param-value>100</param-value>
>         </init-param>
>         <init-param>
>           <param-name>debug</param-name>
>           <param-value>6</param-value>
>         </init-param>
>         <init-param>
>           <param-name>cgiPathPrefix</param-name>
>           <param-value>WEB-INF/cgi-bin</param-value>
>         </init-param>
>     </servlet>
> 
> 
>     <servlet-mapping>
>         <servlet-name>cgi</servlet-name>
>         <url-pattern>/cgi-bin/*</url-pattern>
>     </servlet-mapping>
> 
> 
> 
> When I places a cgi script out there to just show a statement, I get
the
> following error....
> 
> HTTP Status 404 - /resporta/cgi-bin/animal.cgi
> 
>
------------------------------------------------------------------------
> --------
> 
> type Status report
> 
> message /resporta/cgi-bin/animal.cgi
> 
> description The requested resource (/resporta/cgi-bin/animal.cgi) is
not
> available.
> 
> 
>
------------------------------------------------------------------------
> --------
> 
> Apache Tomcat/4.1.18
> 
> -----Original Message-----
> From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com] 
> Sent: Tuesday, September 23, 2003 11:47 AM
> To: Tomcat Users List
> Subject: RE: Configuring and using cgi scripts in Tomcat
> 
> 
> 
> Howdy,
> There's more than uncommenting involved.  You have to follow all the
> instructions in those comments, including the jar file rename and
tomcat
> restart.  Then you have to give us much more information about what
> errors you're seeing.
> 
> Yoav Shapira
> Millennium ChemInformatics




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message