tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <>
Subject RE: deployment problems - solved (for the moment ;-))
Date Fri, 19 Sep 2003 13:09:57 GMT


>b) /opt/jakarta/tomcat/webapps/ROOT/WEB-INF/web.xml had no entries at
>all for any servlets, not even in comments. (i believe this is tomcat
>4.1.18-25 as it came out of the SuSE 8.2 box: however, my previous
>efforts to make things work may have corrupted this, i simply cannot
>backtrack that far). i added
>and then stuff that worked in the examples directory also worked in
>ROOT, using URL="http://localhost:8080/servlet/{MyServlet}"
>given that this line is so essential to the functioning of the whole
>setup, i wonder it wasn't in that file to begin with. any ideas?

This line is NOT essential.  It's a security risk which is why it was
commented out (not removed -- it's present in
$CATALINA_HOME/conf/web.xml) disabled by default in tomcat 4.1.18 and

A better practice is to define and map discrete servlets, not using the
invoker servlet.

Nonetheless, thanks for posting the solutions to your problem.  It's
good when people can read a whole thread in the archives.

Yoav Shapira

This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.

View raw message