tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: Tomcat 4.1 -> 5.0 Web-app Porting
Date Mon, 15 Sep 2003 13:48:02 GMT

Howdy,

>I still don't understand how this works with Tomcat 4.1 and not 5.0. I
>thought 5.0 was backwards compatible. 

Well, that's a nice entertaining start to my week ;)

The standards (Servlet and JSP specifications) are backwards compatible.
So things that implement them will be backwards compatible.  However,
features of the server not mandated by the specification (e.g. server
configuration, non-standard features) are not guaranteed to be
backwards-compatible.

Moreover, tomcat 5 is not yet mature.  You are helping us test it and
find bugs, for which we are grateful ;)


>Besides, struts' tags are very
>popular (<html><bean> etc.). If 5.0 were somehow not compatible with
these
>tags, we would hear more complaints from this forum.

We would, I agree, if more people assumed tomcat 5 was production-ready.
Not many people make this assumption now.  Many people are waiting for a
tomcat 5 stable release, which hasn't happened (and won't until the
specs are final).  When the first stable release comes out, I expect to
see a lot more tomcat 5 "bug reports" as there will be many more
users/testers.  It's natural for every product ;)

Yoav Shapira



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


Mime
View raw message