tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Popiol" <vpop...@comerxia.com>
Subject Threads don't go back to pool!
Date Fri, 12 Sep 2003 16:31:03 GMT
Hi. When I obtain a jkstatus, during time, the epCount value keeps
increasing. So it seams like the threads are never returned to the pool.
I set the connectionTimeout to 20000 (Isuppose 20 secs.) but no help.

 

In the jk2.log I see a lot of messages like this:

 

[Thu Sep 11 10:47:21 2003] (error ) [jk_worker_ajp13.c (416)]
ajp13.service() ajpGetReply recoverable error 3

[Thu Sep 11 10:47:22 2003] (error ) [jk_service_iis.c (157)]
jk_ws_service_t::head, ServerSupportFunction failed

[Thu Sep 11 10:47:22 2003] (error ) [jk_handler_response.c (178)]
handler.response() Error sending response[Thu Sep 11 10:47:22 2003]
(error ) [jk_worker_ajp13.c (416)]  ajp13.service() ajpGetReply
recoverable error 3

 

Also, I get messages like this:

 

[Thu Sep 11 12:43:45 2003] (error ) [jk_channel_socket.c (557)]
channelSocket.receive(): Error receiving message body -1 53

[Thu Sep 11 12:43:45 2003] (error ) [jk_workerEnv.c (482)]
workerEnv.processCallbacks() Error reading reply

[Thu Sep 11 12:43:45 2003] (error ) [jk_worker_ajp13.c (416)]
ajp13.service() ajpGetReply recoverable error 120000

 

Thanks

Victor Popiol

Chief Technology Officer & Co-Founder
Comerxia, Inc. (formerly DoUWantIt.com)
Ph: 954-862-0020

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message