tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Volker <Tom...@Trendsetter.de>
Subject Tomcat stops working after a few days!
Date Fri, 26 Sep 2003 07:03:57 GMT
Hi,

I have a problem running Jakarta Tomcat 4.1 port under FreeBSD 4.4 with
Blackdown Java 1.3.1 with mod_jk 1.2:

After startup.sh /logs/catalina.out shows up following lines:

[INFO] Registry - -Loading registry information
[INFO] Registry - -Creating new Registry instance
[INFO] Registry - -Creating MBeanServer
[INFO] Http11Protocol - -Initializing Coyote HTTP/1.1 on port 8080
Starting service Tomcat-Standalone
Apache Tomcat/4.1.24
HTTP Tunnel connected to the DigiChat server localhost
HttpTunnelingServlet connected to the groopz server
[INFO] Http11Protocol - -Starting Coyote HTTP/1.1 on port 8080
[INFO] ChannelSocket - -JK2: ajp13 listening on 0.0.0.0/0.0.0.0:8009
[INFO] JkMain - -Jk running ID=0 time=7/21
config=/usr/local/jakarta-tomcat4.1/conf/jk2.properties
[INFO] ChannelSocket - -server has been restarted or reset this
connection
[INFO] ChannelSocket - -server has been restarted or reset this
connection
[INFO] ChannelSocket - -server has been restarted or reset this
connection
[INFO] ChannelSocket - -server has been restarted or reset this
connection

The first days everythings runs correctly. The example servlets can be
executed via port 80 by help of mod_jk.

After a few days suddenly the servlets cannot be executed anymore.
Having a look on the Tomcat process with "top" prints out state
"sbwait".
That state does not change anymore AND I cannot shutdown the tomcat
process by help of shutdown.sh - so I have to kill the process with kill
-9.

"catalina.out" meanwhile has grown up to nearly 1MB because a lot of
lines (content: [INFO] ChannelSocket - -server has been restarted or
reset this connection ) have been inserted.

Killing and restarting Tomcat manually and restarting apache afterwards
for activating mod_jk again results in making all work again.

Does anyone have an idea of what is happening here?


Thanks and regards

Volker




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message