tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Jesso" <jje...@global-matrix.com>
Subject adding a servlet to my webapp
Date Wed, 03 Sep 2003 18:27:43 GMT
When I go to my servlet I get "HTTP Status 404 - 
/jasonTest/servlet/foo/HelloWorld"

The url is:
http://neptune/jasonTest/servlet/foo/HelloWorld

My config is as follows:  (What is wrong here??)

I have a webapp defined in server.xml as

=======================
       <Context path="/jasonTest"
            docBase="jasonTest"
            debug="0"
            reloadable="true"
            crossContext="true">
            <Logger className="org.apache.catalina.logger.FileLogger" 
prefix="jasonTest" suffix=".out"/>
        </Context>
=======================


My webapp directory structure looks like:
=======================
neptune:root> ls -lR jasonTest/
total 16
drwxr-sr-x   4 root     software        512 Sep 03 10:18 WEB-INF
-rw-r--r--   1 root     software         43 Sep 03 10:10 index.html
jasonTest/WEB-INF:
total 24
drwxr-sr-x   3 root     software        512 Sep 03 11:12 classes
drwxr-sr-x   2 root     software        512 Sep 03 10:09 lib
-rw-r--r--   1 root     software        328 Sep 03 14:22 web.xml

jasonTest/WEB-INF/classes:
total 8
drwxr-sr-x   2 root     software        512 Sep 03 10:31 foo

jasonTest/WEB-INF/classes/foo:
total 8
-rw-r-----   1 root     software        815 Sep 03 10:31 HelloWorld.class

jasonTest/WEB-INF/lib:
total 0
neptune:root>
=======================

My web.xml looks like:

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    "http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>

 <servlet>
    <servlet-name>HelloWorld</servlet-name>
    <servlet-class>/servlet/foo/HelloWorld</servlet-class>
 </servlet>

</web-app>


-- 
<jason/>




Mime
View raw message