tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gustavo A. Baratto" <gbara...@superb.net>
Subject newbie question
Date Wed, 03 Sep 2003 16:53:26 GMT
I can see tomcat 4.1.27 working fine (including executing the examples) 
when I go to http://localhost:8080 and to http://localhost/jkstatus, but 
I am having problems connecting apache2 to tomcat through mod_jk2. I am 
getting 500 error when I go to http://localhost/examples


Another thing... I don't keep my httpd.conf in ${serverRoot}/conf, so I 
had to create this dorectory to keep workers2.properties. How do I set 
tomcat or mod_jk to look for workers2.properties in a non-standard 
directory?


This one is on a freebsd 5.1 box, with apache 2.0.47

jk2.properties is all commented out, and this is my workers2.properties:
-------
# Define the communication channel
[channel.socket:localhost:8009]
info=Ajp13 forwarding over socket
tomcatId=localhost:8009

# Map the Tomcat examples webapp to the Web server uri space
[uri:/examples/*]
worker=ajp13:localhost:8019

# define the worker
[status:status]
# Uri mapping
[uri:/jkstatus/*]
worker=status:status
------------

This is server.xml:
--------
<Server port="8005" shutdown="SHUTDOWN" debug="0">
   <Service name="Tomcat-Standalone">
     <Engine name="Standalone" defaultHost="localhost" debug="0">

	<Host name="localhost" debug="0" appBase="webapps"
        	unpackWARs="true" autoDeploy="true">
		<Context path="/examples" debug="0" privileged="true" 				 
docBase="examples">
		</Context>
	</Host>
     </Engine>
   </Service>
</Server>
--------

Any idea is very much appreciated :)

thanks


Mime
View raw message