tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Turner <tomcat-u...@johnturner.com>
Subject Re: TC 4.1.24 can't find my servlet-classes?
Date Tue, 02 Sep 2003 12:32:34 GMT

http://jakarta.apache.org/tomcat/faq/misc.html#invoker

John

Kenneth Ahn Jensen wrote:

> After using Tomcat for a long time, I seem to be getting into trouble
> lately. My Tomcat suddenly does not automatically find the servlets in
> <context-dir>/WEB-INF/classes - so I have to make a web.xml file for each
> context.
> 
> My server.xml is pretty much like the original, except for the user contexts
> which all look like this:
> 
>  <Context path="/user/testuser" docBase="user/testuser" debug="0"
>   reloadable="true" crossContext="true"/>
> 
> The servlets are then placed like:
> {$CATALINA_HOME}/webapps/user/testuser/WEB-INF/classes/HelloWorld.class
> 
> However, I get a 404 error when requesting
> http://ip:port/user/testuser/servlet/HelloWorld - which I'm pretty sure
> worked until a month ago (when the system crashed). Also I know for a fact
> that it works on TC 4.04.
> 
> The {$CATALINA_HOME}/webapps/user/testuser/index.jsp gets loaded just fine
> from the URL http://ip:port/user/testuser/index.jsp, so Tomcat has noticed
> the context.
> 
> Any input will be much appreciated, as I have been trying to make this work
> for some time now and I don't seem to get closer... :-(
> 
> The server is running students servlets on a university, and a lot of them
> are just beginning on programming, so they shouldn't care about deployment
> details (at least thats what the teachers tell me, the sysadmin :-).
> 
> I'm running Tomcat 4.1.24 with Sun Java 1.4.2 on Redhat 8.0 (and Mandrake
> 9.1).



Mime
View raw message