tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <craig...@apache.org>
Subject Re: Tomcat 4.1 -> 5.0 Web-app Porting
Date Fri, 12 Sep 2003 22:44:13 GMT
On Fri, 12 Sep 2003 prashant.budhale@acterna.com wrote:

> Date: Fri, 12 Sep 2003 16:01:57 -0500
> From: prashant.budhale@acterna.com
> Reply-To: Struts Users Mailing List <struts-user@jakarta.apache.org>
> To: tomcat-user@jakarta.apache.org
> Cc: struts-user@jakarta.apache.org
> Subject: Tomcat 4.1 -> 5.0 Web-app Porting
>
> Hi,
> I am trying to port a web-application originally written with Tomcat 4.1 to
> Tomcat 5.0. The application uses struts and throws the following exception
> when launched:
>
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> The server encountered an internal error () that prevented it from
> fulfilling this request.
>
>
> exception
> java.lang.NullPointerException
>
> org.apache.jasper.runtime.TagHandlerPool.reuse(TagHandlerPool.java:176)
>              com.acterna.cable.rda.index_jsp.
> _jspx_meth_bean_message_0(index_jsp.java:119)
>              com.acterna.cable.rda.index_jsp._jspService(index_jsp.java:67)
>
> org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:133)
>              javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>

Which specific version of Tomcat 5.0.x are you trying?  I seem to recall
that there were a couple of bugs in the tag pooling code that could bite
you in a page with lots of tags (typical of Struts apps), but that these
bugs were fixed in 5.0.9.

If that doesn't fix the problem, you can also turn off tag pooling with a
servlet init parameter -- read the docs in "$CATALINA_HOME/conf/web.xml"
for which one needs to be set.

Craig

Mime
View raw message