tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mats Wolpers <matthias.wolp...@freenet.de>
Subject RE: deployment problems - solved (for the moment ;-))
Date Fri, 19 Sep 2003 07:19:03 GMT
Hello,
(cont. my posting of September 12.)
I took Yoav's hint and undid all the jibberish i had done so far and
double-rechecked those dirs. still didn't work. 
i read marty hall's chapter 1 from *more servlets and jave server pages*
and played with the advice given there. stuff works now. i believe the
following two things did the trick between them:

a) the java compiler needs that classpath environment variable. i added
to my ~/.bashrc (make a backup before trying this at home!) the line
export
CLASSPATH=".":/opt/jakarta/tomcat/common/lib/servlet.jar:{my-*.java-work-directory}

b) /opt/jakarta/tomcat/webapps/ROOT/WEB-INF/web.xml had no entries at
all for any servlets, not even in comments. (i believe this is tomcat
4.1.18-25 as it came out of the SuSE 8.2 box: however, my previous
efforts to make things work may have corrupted this, i simply cannot
backtrack that far). i added
<servlet-mapping>
<servlet-name>invoker</servlet-name>
<url-pattern>/servlet/*</url-pattern>
</servlet-mapping>
and then stuff that worked in the examples directory also worked in
ROOT, using URL="http://localhost:8080/servlet/{MyServlet}"

given that this line is so essential to the functioning of the whole
setup, i wonder it wasn't in that file to begin with. any ideas?

i tried this with a really simple servlet first (again: marty hall's
advice). then i retried with our course project, that also works now.

thanks all who helped, mats



Mime
View raw message