tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zepiroth Hong" <hig...@indo.net.id>
Subject Re: Tomcat connector for Apache 2.0.47 ... Please Help
Date Fri, 26 Sep 2003 01:42:48 GMT
Dear Dean,

If it is possible, I would like to get one of your copy of the full
installation documentation.
I have the same problem with Joe.

Thanks in advance.

Best regards.

Hong.

----- Original Message -----
From: "Dean Searle" <Dean@computingoasis.com>
To: "Tomcat Users List"
<tomcat-user@jakarta.apache.orgjmihalich@formalogix.com>;
<tomcat-user@jakarta.apache.org>
Sent: Friday, September 26, 2003 6:43 AM
Subject: RE: Tomcat connector for Apache 2.0.47 ... Please Help


> Joe,
>
> You place the mod_jk2 file in the correct folder, however you have set up
the parameters in your httpd.conf file incorrectly. The parameters you have
are for the mod_jk module. For the mod_jk2 module you would need a
workers2.properties file and a jk2.shm file.
>
> I have documented a full install of Apache 2.0.46 and Tomcat 4.1.26. on
Windows 2000, but I have used the same instructions on my WinXP Pro with out
any problems. If this mail list would not mind me sending this document
please let me know.
>
> This is information I have compiled from numerous mail lists and debugged
for many months. The document is about 20 pages long give or take. I don't
have it in front of me at this time. I can post it as a pdf or RTF. Let me
know which version is more acceptable.
>
>
> Dean
>
> -----Original Message-----
> From: Joe Mihalich [mailto:jmihalich@formalogix.com]
> Sent: Thu 9/25/2003 7:29 PM
> To: tomcat-user@jakarta.apache.org
> Cc:
> Subject: Tomcat connector for Apache 2.0.47 ... Please Help
>
>
>
>
>
>
>
>
>
> Hi,
>
>
>
>                I've installed Apache version 2.0.47, and tomcat version
> 4.1.27 on a windows xp box.
>
>
>
>                I've downloaded the mod_jk2-2.0.43.dll connector, and put
it
> in the modules directory
>
>             Under apache.
>
>
>
>                I configured tomcat to auto generate the mod_jk.conf file.
>
>
>
>                All that is working ok.so it seems.
>
>
>
>                I then modified the httpd.conf file as follows:
>
>
>
> LoadModule jk_module modules/mod_jk2-2.0.43.dll
>
> AddModule mod_jk.c
>
>
>
> JkWorkersFile \Program Files\Apache
> Group\jakarta-tomcat-4.1.27\conf\jk\workers.properties
>
> JkLogFile logs\mod_jk.log
>
> JkLogLevel debug
>
>
>
>                And added this include, at the end of the file
>
>
>
> Include \Program Files\Apache
> Group\jakarta-tomcat-4.1.27\conf\auto\mod_jk.conf
>
>
>
>                Now, when I try to start up apache, I'm getting this error:
>
>
>
> Syntax error on line 173 of C:/Program Files/Apache
> Group/Apache2/conf/httpd.conf:
>
> Can't locate API module structure `jk_module' in file C:/Program
> Files/Apache Gr
>
> oup/Apache2/modules/mod_jk2.dll: No error
>
>
>
>                Line 173 is the "LoadModule" line above.
>
>
>
>                Can someone please tell me why I'm getting this error?  In
> the download
>
>             Directory for mod_jk2-2.0.43.dll, it says that this file is
only
> for Apache 2.0.43.
>
>             I assume that it will work for 2.0.47.or is that the problem
> here?  I can't
>
>             Find 2.0.43 to download anymore.
>
>
>
>                Also, I'm confused as to why all the other modules in the
> modules sub directory
>
>             Have the ".so" extension.  Aren't those unix shared library
> objects?  Can they work
>
>             On windows?
>
>
>
>                Anyway, any help would be appreciated.
>
>
>
>             Thanks,
>
>             Joe
>
>
>
>
>
>
>
>


Mime
View raw message