tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Tulley" <JTUL...@novell.com>
Subject Re: Tomcat 4.1 & https problem
Date Wed, 06 Aug 2003 20:33:04 GMT
Try simply "catalina run" to have it run in the current window.  Then
see what exception you get. (Hopefully you are on an OS that will allow
you to scroll back and see the exception)

Jeff Tulley  (jtulley@novell.com)
(801)861-5322
Novell, Inc., The Leading Provider of Net Business Solutions
http://www.novell.com

>>> Rowena.Hou@scr.siemens.com 8/6/03 2:23:05 PM >>>
Hi,

I've been running Tomcat as a standalone Web server for a while. My
project
run fine at http with sign applet. I want to switch from HTTP to HTTPS.

I followed the directions in the document"
http://jakarta.apache.org/tomcat/tomcat-4.1-doc/ssl-howto.html" : 

   1. keytool -genkey -alias tomcat -keyalg RSA -keystore mykeystore
   2. keytool -certreq -keyalg RSA -alias tomcat -file certreq.csr
-keystore
mykeystore
   and
   3. uncommented the connector provided by the config file:
       <Connector
className="org.apache.coyote.tomcat4.CoyoteConnector"
         port="8443" minProcessors="5" maxProcessors="75"
         enableLookups="true"
         acceptCount="10" debug="0" scheme="https" secure="true"
         useURIValidationHack="false">
        <Factory
className="org.apache.coyote.tomcat4.CoyoteServerSocketFactory"
           clientAuth="false" protocol="TLS" 
           keystoreFile="full path to mykeystore" 
           keystorePass- "changeit" 
        />
     </Connector>

However, it isn't working. I can't start Tomcat at all. I don't get
any
errors at prompt or in the logs; I tried to use command window run
"start
tomcat". It popup a command prompt and disappear. If I change className
to 
<Factory className="org.apache.catalina.net.SSLServerSocketFactory" 
which used in document. I can start Tomcat and get
"http://localhost:8443"
work but not https://localhost:8443 ( I commented out connector for
http in
server.xml file).
I use jakarta-tomcat-4.1.12-LE-jdk14 which come with jbuilder 8. runing
on
Window 2000 and IE 6

Question:
1. How can I fix the problem.
2. How can I find out error message? I tried to rum "catalina debug
-security" from command prompt. Most of error message is unrecognized.




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org 
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org 


Mime
View raw message