tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject jdk 1.4 logging and log formatter class not being found
Date Sat, 23 Aug 2003 20:26:20 GMT
I just upgraded from 4.1.24 to 4.1.27 and found that tomcat or java now 
can't find my formatter class which I need for JDK 1.4 logging.

if you're not familiar with JDK 1.4 logging, the formatter class is what 
you specify in the logging.properties config file, which formats the 
output of the each log statement.

There are a couple of standard formatter classes in JDK 1.4 which I have 
tested out and they work fine still, so the problem is definitely that 
my formatter class is not being found. When JDK 1.4 logging can't find 
the formatter you specify, it reverts back to the default one.

I have the formatter class in tomcat's common/classes directory. 
Switching back to 4.1.24, it still works.

I've tried placing my class in server/classes, in shared/classes and 
also in WEB-INF/classes for a particular webapp, with no joy. Does 
anybody have any idea what I can do?


thanks
Adam


ps in both 4.1.24 and 27 I am using the LE binaries. I have also tried 
it with the old commons-logging.jar and with the latest jar - not that 
it should affect it, but I've been trying everything in desperation.


-- 
struts 1.1 + tomcat 4.1.27 + java 1.4.2
Linux 2.4.20 RH9


Mime
View raw message