tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Turner <tomcat-u...@johnturner.com>
Subject Re: Tomcat MultiHosting problems
Date Mon, 18 Aug 2003 17:48:06 GMT

Have you used separate appBases for each host?

What are the error messages?

What are the log contents when the URL does not work?

John

Robert Zöhrer @ pronet.at wrote:

> 8/18/2003 2:25 PM John Turner:
> 
>>appBase != docBase
>>
>>Right now your Context is using the same value for its docBase as your 
>>Host is using for its appBase.  Your docBase cannot be your appBase, not 
>>to mention that your Context is using a path of "/webapps" which could 
>>cause all sorts of weird problems.
>>
>>Set appBase = /home/www/vhostxx/html/webapps but then set docBase = 
>>"myApp" or something like that (it is automatically relative to the 
>>appBase).
> 
> 
> Thanks 4 answer John
> 
> We don't use appBase = docBasethe and the term "webapps" as path- or
> dir-name any longer .. but another mistake was definititly the
> ownership of the appBase-dir .. the user "tomcat4" was not in the same
> group as the owner of appBase.
> 
> drwxr-xr-x    3 web10    ftponly      4096 Aug 18 15:08 appbase_dir
> 
> Now the user "tomcat" is in ftponly group too .. and "he" got the dir now.
> 
> But now I've some very hard troubles with a test.jsp file, which works
> in one host, but in 3 others (with exactly the same seetings) it
> doesn't :( .. and I've no idea, why :(
> 
> test.jsp:
> ################
> <% for (int i=0; i < 10; i++) { %>
> zeile <%= i %> <br>
> <% } %>
> ################
> 
> At http://webteam.at:8080/tomcat/test.jsp it works
> 
> docBase:
> 
> drwxr-xr-x    2 web156   ftponly      4096 Aug 18 16:09 tomcat
> 
> and the file:
> 
> -rwxrwxrwx    1 web156   ftponly        64 Aug 16 18:32 test.jsp
> 
> but at
> 
> http://pronet.at:8080/tomcat/test.jsp  I get an error, as seen in the
> browser
> 
> docBase in this case .. same permissions:
> 
> drwxr-xr-x    2 web10    ftponly      4096 Aug 18 18:37 tomcat
> 
> File:
> 
> -rwxrwxrwx    1 web10    ftponly        64 Aug 18 16:01 test.jsp
> 
> There is another host I've tried with different directory names .. but
> allways the same error:
> 
> AppBase: /home/www/web200/html/servlet
> 
> docBase: myapp
> 
> http://eko-immobilien.at:8080/myapp/test.jsp
> 
> I can't see any differences between all these hosts and context
> settings .. but the jsp only works with
> http://webteam.at:8080/tomcat/test.jsp.
> 
> Another "crazy" thing: At the admin panel I can see further hosts and
> contexts, which are NOT in the actual server.xml .. and if I want to
> delete them, I get an error.
> 
> I'm very despairing  .. so if anybody could help me ..
> 
> Many, many Thanks
> Robert
> 



Mime
View raw message