tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Angus Mezick" <amez...@guidestar.org>
Subject RE: TOMCAT x WSAD
Date Thu, 07 Aug 2003 17:02:10 GMT
What is WSAD?  What ever it is, it had a brain fart most likely.

> -----Original Message-----
> From: Oscar (Eccox) [mailto:oscar.eduardo@eccox.com.br] 
> Sent: Thursday, August 07, 2003 10:46 AM
> To: 'Tomcat Users List'
> Subject: RES: TOMCAT x WSAD
> 
> 
> No, my application is not in the root directory... It is in
> $TOMCAT_HOME/webapps... And this is the error: WSAD is putting a slash
> in the docBase string, instead of leaving 'application' alone, that
> means a relative path to $TOMCAT_HOME/webapps... Why WSAD puts this
> slash ???
> 
> Thanks for your colaboration...
> 
> ===========================
> José Oscar de Souza Eduardo
> Coordenador de Projetos
> tel: 3047-4541
> fax: 3047-4550
> oscar.eduardo@eccox.com.br
> =========================== 	
>  
> 
> 
> -----Mensagem original-----
> De: Angus Mezick [mailto:amezick@guidestar.org] 
> Enviada em: quinta-feira, 7 de agosto de 2003 11:12
> Para: Tomcat Users List
> Assunto: RE: TOMCAT x WSAD
> 
> 
> Application is in your root directory?  You docBase seems to think so.
> --Angus
> 
> 	-----Original Message-----
> 	From: Oscar (Eccox) [mailto:oscar.eduardo@eccox.com.br] 
> 	Sent: Thursday, August 07, 2003 9:11 AM
> 	To: tomcat-user@jakarta.apache.org
> 	Subject: TOMCAT x WSAD
> 	
> 	
> 	Hi, List,
> 	 
> 	I'm using WSAD with TOMCAT... When I select 'Run On Server' in
> the WSAD menu, the TOMCAT starts in debug mode and the Navigator opens
> and points to my index.jsp page, for example. But, I receive 
> the error:
> 	 
> 	
> 
> 	HTTP Status 404 - /application/index.jsp
> 
>   _____  
> 
> 
> 	type Status report
> 
> 	message /application/index.jsp
> 
> 	description The requested resource (/application/index.jps) is
> not available.
> 
>   _____  
> 
> 
> 	Apache Tomcat/4.1.24
> 
> 	Looking in the $TOMCAT_HOME/conf/server.xml, I find this line:
> 	 
> 	<Context docBase="/application" path="/application"
> reloadable="true" source="application"/>
> 
> 	And, when I remove the slash in docBase, and then restart
> TOMCAT, mannualy, everything works fine...
> 	This line is created automatically by WSAD in server.xml...
> Anybody knows why it creates the line with this error ????
> 	 
> 	Thanks,
> 	 
> 	PS. In the project properties (WSAD), in the Web section, the
> 'Context Root' parameter is 'myweb', different from 
> 'application'. WSAD
> is using the project name instead of context root for create 
> the line in
> server.xml...
> 	 
>  	===========================
> José Oscar de Souza Eduardo
> Coordenador de Projetos
> tel: 3047-4541
> fax: 3047-4550
> oscar.eduardo@eccox.com.br
> =========================== 	
> 	 
> 	 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 

Mime
View raw message