tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Kandy <Vij...@mailcode.com>
Subject RE: sendRedirect() doesnt work in https (posted again)
Date Wed, 06 Aug 2003 15:22:39 GMT
FYI in case anyone else have this issue,

I got this fixed with the help of this article:
http://www.jguru.com/faq/view.jsp?EID=445939

Apparently, sendRedirect()s were going to localhost, so I changed
webapp.conf so that WebAppConnection maps to proper domain name:port
(instead of localhost) like so:
WebAppConnection warpConn warp domainName:9003

--Vijay

 -----Original Message-----
From: 	Vijay Kandy  
Sent:	Monday, August 04, 2003 4:40 PM
To:	'Tomcat Users List'
Subject:	sendRedirect() doesnt work in https (posted again)

Help anyone?

Hello Everyone,

I recently installed mod_ssl on an Apache 2.0.44/Tomcat 4.0.3/Debian 2.4.18
machine. I used openssl to create certificate and key and most of the web
application works fine. The only part that seems broken is when
sendRedirect() is used. I used something along the lines of:
res.sendRedirect(req.getContextPath() + "/" + "ServletName"); Is this not
legal? Could someone let me know why it does not work.

Sincerely,
Vijay

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

Mime
View raw message