tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Stewart <SStew...@csky.com>
Subject RE: Tomcat 4.1 & https problem
Date Fri, 08 Aug 2003 13:14:40 GMT
I am running Tomcat 4.1.24 in standalone mode using https with no problems.

How do you have the non-SSL and SSL Connectors defined in your server.xml?
Also, where do your key/cert files live (i.e. within the Tomcat directory
structure somewhere)?

Thanks,

Scott Stewart
[Manager, Software Development]
SStewart@csky.com

ClearSky Mobile Media, Inc.
56 E. Pine St. Suite 200
Orlando, FL 32801
USA



-----Original Message-----
From: Tim Davidson [mailto:tim.davidson@greenhatconsulting.com] 
Sent: Friday, August 08, 2003 9:08 AM
To: Tomcat Users List
Subject: RE: Tomcat 4.1 & https problem


I had the same problem, it seems to occur when you uncomment the connector
in server.xml and causes tomcat to exit, making it impossible to see what
the error message was. I gave up in the end. Have you been able to get it
working?

-----Original Message-----
From: tangwenmin@citiz.net [mailto:tangwenmin@citiz.net]
Sent: Friday, August 08, 2003 12:42 PM
To: Tomcat Users List; tomcat-user@jakarta.apache.org
Subject: Re: Tomcat 4.1 & https problem


Hou, Rowena,您好!
	you may by change server.xml like this,try again. You will be
sucessful.
	           keystoreFile="mykeystore" 
           keystorePass = "password" 

======= 2003-08-06 16:23:00 您在来信中写道:=======

>Hi,
>
>I've been running Tomcat as a standalone Web server for a while. My 
>project run fine at http with sign applet. I want to switch from HTTP 
>to HTTPS. I followed the directions in the document" 
>http://jakarta.apache.org/tomcat/tomcat-4.1-doc/ssl-howto.html" :
>
>   1. keytool -genkey -alias tomcat -keyalg RSA -keystore mykeystore
>   2. keytool -certreq -keyalg RSA -alias tomcat -file certreq.csr 
>-keystore mykeystore
>   and
>   3. uncommented the connector provided by the config file:
>       <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
>         port="8443" minProcessors="5" maxProcessors="75"
>         enableLookups="true"
>         acceptCount="10" debug="0" scheme="https" secure="true"
>         useURIValidationHack="false">
>        <Factory 
>className="org.apache.coyote.tomcat4.CoyoteServerSocketFactory"
>           clientAuth="false" protocol="TLS" 
>           keystoreFile="full path to mykeystore" 
>           keystorePass- "changeit" 
>        />
>     </Connector>
>
>However, it isn't working. I can't start Tomcat at all. I don't get any 
>errors at prompt or in the logs; I tried to use command window run 
>"start tomcat". It popup a command prompt and disappear. If I change 
>className to <Factory 
>className="org.apache.catalina.net.SSLServerSocketFactory"
>which used in document. I can start Tomcat and get "http://localhost:8443"
>work but not https://localhost:8443 ( I commented out connector for http in
>server.xml file).
>I use jakarta-tomcat-4.1.12-LE-jdk14 which come with jbuilder 8. runing on
>Window 2000 and IE 6
>
>Question:
>1. How can I fix the problem.
>2. How can I find out error message? I tried to rum "catalina debug 
>-security" from command prompt. Most of error message is unrecognized.
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

= = = = = = = = = = = = = = = = = = = =
			

        致
礼!
 
				 
        唐文民
        tangwenmin@citiz.net
          2003-08-08




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

Mime
View raw message