tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shannon Scott" <>
Subject Apache SSl with mod_jk
Date Thu, 21 Aug 2003 16:44:20 GMT
I have set up the apache webserver do ssl and it works well, but the .jsp files are not found
even though they are in the same directory.     works       doesn't work

My httpd.conf has the following:
<VirtualHost _default_:443>
ErrorLog logs/ssl_error_log
TransferLog logs/ssl_access_log
Alias /ssl /var/tomcat4/webapps/ROOT/ssl
    JkMount /ssl/servlet/* ajp13
    JkMount /ssl/*.jsp ajp13

SSL stuff...

I have noticed that nmap shows the following line:
8009/tcp   open        ajp13

And in the server.xml I have defined the connectors like this:
     <!-- Define an AJP 1.3 Connector on port 8009 -->
     <Connector className="org.apache.ajp.tomcat4.Ajp13Connector" 
             port="8009" minProcessors="5" maxProcessors="150"
             redirectPort="8543" acceptCount="10" debug="0" 

     <!-- Define an AJP 1.3 Connector on port 8543 -->
    <Connector className="org.apache.ajp.tomcat4.Ajp13Connector" 
               port="8543" minProcessors="5" maxProcessors="150"
               enableLookups="true" acceptCount="10" 
                     debug="0" scheme="https" secure="true" connectionTimeout="0"/>

Do I need to open the 8543 port on the server for https?
Any help is greatly appreciated.
Thank You.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message