tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Turner <tomcat-u...@johnturner.com>
Subject Re: Apache 1.3.27, Tomcat 4.1 & mod_jk, not working
Date Wed, 16 Jul 2003 20:03:17 GMT

Did you configure mod_jk?  JkMount, JkLogLevel, etc?

- change JkLogLevel to "info" and post the results from mod_jk log file

- post JkMount and the URL you are trying to use, as well as your Apache 
virtual host config

John

On Wed, 16 Jul 2003 12:50:57 -0700, Bongrip <tomcat@echeeba.com> wrote:

>
> I build an apache 1.3.27 server and mod_jk as a DSO and it loads 
> correctly and is recognized by the apache server.
>
> The mod_info module shows the module as being active and it lists my 
> custom config.
>
> Here is my config:
> worker.list=worker1
>
> worker.worker1.type=ajp13
> worker.worker1.host=localhost
> worker.worker1.port=8009
> worker.worker1.lbfactor=50
> worker.worker1.cachesize=10
> worker.worker1.cache_timeout=600
> worker.worker1.socket_keepalive=1
> worker.worker1.socket_timeout=300
>
>
> I am enabled the Coyote connector on my Tomcat server.
> Apache Tomcat/4.1.24
> Jul 16, 2003 11:53:28 AM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on port 8080
> Jul 16, 2003 11:53:28 AM org.apache.jk.common.ChannelSocket init
> INFO: JK2: ajp13 listening on /0.0.0.0:8009
> Jul 16, 2003 11:53:28 AM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=1/174 
> config=/usr/local/tomcat/conf/jk2.properties
> Jul 16, 2003 11:53:59 AM org.apache.jk.common.ChannelSocket 
> processConnection
> INFO: server has been restarted or reset this connection
> Jul 16, 2003 11:53:59 AM org.apache.jk.common.ChannelSocket 
> processConnection
> INFO: server has been restarted or reset this connection
> Jul 16, 2003 11:56:43 AM org.apache.jk.common.ChannelSocket 
> processConnection
> INFO: server has been restarted or reset this connection
>
> When I try to access a jsp page it gives me error 404. But the file is 
> there and is readable by all. (0644) I am running tomcat 4.1.24 and using 
> Sun's j2sdk 1.4.1 rev 03. I get nothing logged to either the apache logs 
> or the tomcat logs when I make a request.
>
> Any ideas?
>
> Thxc,
> CC
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>



-- 
Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message