tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Turner <tomcat-u...@johnturner.com>
Subject Re: JK2 problems
Date Tue, 15 Jul 2003 12:33:59 GMT

OK, now we have more information.

Apache 1.3.20?  Godd luck getting mod_jk or mod_jk2 to work.  You will need 
to build your own connector from source, and if it were me, I wouldn't 
waste any time whatsoever on JK2 with 1.3.20.  Even JK is dicey.

There is a complete Linux HOWTO here: http://www.johnturner.com/howto.  It 
is for JK, and it is as painless as I can make it.  Every change to default 
configuration files, without exception, is described.

Your first problem will be getting an Apache module compatible with 1.3.20. 
 Once that is done, the rest is easy.

John

On Tue, 15 Jul 2003 14:03:45 +0200, Werner van Mook <werner@connecties.com> 
wrote:

> Hi Again,
>
> after a not succesfull attempt to get mod_jk working I'm now trying to 
> get
> mod_jk2 to work.
>
> Apache 1.3.20
> tomcat 4.1.24
> linux customized version of RedHat  2.2.16C35_III
> It's a sun cobalt box somewhere in europe. This means it's not in my room 
> so I can't touch the box or do anything with it.
> Only remote access is possible.
>
> httpd.conf additions :
>
> LoadModule jk2_module modules/mod_jk2.so
>
> <IfModule mod_jk2.so>
> AddModule mod_jk2.c
> JKWorkersFile /etc/httpd/conf/workers.properties
> </IfModule>
>
>
>
> worker2.properties :
>
> [shm]
> info=Scoreboard. Required see tomcat book pg 116
> file=/etc/httpd/logs/shm.file
> size=1000000
> debug=0
> disabled=0
>
> #my server is not a localhost
> # or is it localhost because apache and tomcat run on the same server?
>
> [channel.socket:localhost:8009]
> info=Ajp13 forwarding over socket
> debug=0
> port=8009
> host=127.0.0.1
>
> # define the worker
> [status:status]
>
> [uri:/jkstatus/*]
> info=Display status information and check the config file for changes
> worker=status:status
>
> # define the worker
> [ajp13:localhost:8009]
> channel=channel.socket:localhost:8009
>
> #The webapp I want to connect to is running on 
> www.connecties.com:8080/Friss
> #Is this mapping correct?
>
> # Uri mapping
> [uri:/Friss/*]
> worker=ajp13:localhost:8009
> debug=1
>
> the generated jk2_log logfile contains :
>
> ( info) [jk_logger_file.c (217)]: Level DEBUG 0
> ( info) [jk_uriEnv.c (211)]: uriEnv.setAttribute() the worker directive 
> is depriciated
> ( info) [jk_uriEnv.c (211)]: uriEnv.setAttribute() the worker directive 
> is depriciated
> ( info) [jk_logger_file.c (177)]: Initializing log file 
> /etc/httpd/logs/jk2.log
> (debug) [jk_uriMap.c (337)]: uriMap.init() Fixing Host *
> (debug) [jk_uriMap.c (423)]: uriMap: fix uri (null) context (null)
> (debug) [jk_uriMap.c (423)]: uriMap: fix uri /jkstatus/* context (null)
> (debug) [jk_uriMap.c (423)]: uriMap: fix uri /Friss/* context (null)
> (debug) [jk_uriMap.c (423)]: uriMap: fix uri (null) context (null)
> (debug) [jk_uriMap.c (423)]: uriMap: fix uri / context /
> (debug) [jk_uriEnv.c (367)]: uriEnv.init() prefix mapping 
> /Friss/=ajp13:localhost:8009
> (debug) [jk_uriEnv.c (386)]: uriEnv.init()  uri:/Friss/*  host=*  
> uri=/Friss/* type=1 ctx=(null) prefix=/Friss/ suffix=(null)
> ( info) [jk_workerEnv.c (403)]: workerEnv.init() ok 
> /etc/httpd/conf/workers2.properties
>
>
> Here is catalina.out :
>
> Jul 15, 2003 1:14:57 PM org.apache.commons.modeler.Registry loadRegistry
> INFO: Loading registry information
> Jul 15, 2003 1:14:57 PM org.apache.commons.modeler.Registry getRegistry
> INFO: Creating new Registry instance
> Jul 15, 2003 1:15:00 PM org.apache.commons.modeler.Registry getServer
> INFO: Creating MBeanServer
> Jul 15, 2003 1:15:04 PM org.apache.coyote.http11.Http11Protocol init
> INFO: Initializing Coyote HTTP/1.1 on port 8080
> Starting service Tomcat-Standalone
> Apache Tomcat/4.1.24
> Jul 15, 2003 1:15:22 PM org.apache.coyote.http11.Http11Protocol start
> INFO: Starting Coyote HTTP/1.1 on port 8080
> Jul 15, 2003 1:15:22 PM org.apache.jk.common.ChannelSocket init
> INFO: JK2: ajp13 listening on /0.0.0.0:8009
> Jul 15, 2003 1:15:23 PM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=4/869  config=/usr/jakarta-tomcat- 
> 4.1.24/conf/jk2.properties
>
> I have changed nothing in server.xml, jk2.properties or any other file 
> that I can think of.
>
> Is there somewhere somebody who can hold my hand and fix it with/for me?
> I need it up and running somewhere next week.
>
> Kind regards
> Werner
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>



-- 
Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message