tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From awisc...@accept-it.de
Subject configuration problem
Date Tue, 15 Jul 2003 12:29:20 GMT
Hi all,

I'am struglling with an application using Lotus Domino Taglibs. When 
accessing the jsp i always get a tomcat error page telling:

...
org.apache.jasper.JasperException: no lsxbe in java.library.path
                 at 
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:254)
                 at 
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:295)
                 at 
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)
.... and so on

For this reason I changed the startup script adding the parameter

         -Djava.library.path="$PATH":/opt/lotus/notes/latest/linux

after this it seems tomcat is able to find the shared library but it'll 
raise another error:

...
org.apache.jasper.JasperException: 
/opt/lotus/notes/60010/linux/liblsxbe.so: libxmlpar.so: cannot load shared 
object file: No such file or directory
                 at 
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:254)
                 at 
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:295)
                 at 
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)
... and so on

the recomended file "libxmlpar.so" is in the same directory as the 
"liblsxbe.so", so i wonder why tomcat can't find this....

the tomcat server is version 4.1 and is  running on SuSE Linux 7.2, my JDK 
is version 1.4.1_02 from Sun.


any help is appreciated
Andreas

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message