tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Menke" <brian.me...@lspeed.com>
Subject RE: XML DOCTYPE problem
Date Thu, 10 Jul 2003 14:42:04 GMT
This seems very strange. Almost any xml editor or xml system uses the public
or system identifier to point to a the DTD so it can vaildate the instance.
The public or system identifier is part of EVERY valid xml file. There must
be some way to handle it?? It's true that the jstl xml parser doesn't
validate it, that's not what I need since I will be producing valid xml, I
just need the jstl x:parse to ignore it so I don't get an error?? Someone
must have run into this before.

Thanks for the help though. I'll keep researching it.

-Brian

-----Original Message-----
From: Abid Ali Teepo [mailto:abid.ali.teepo@mogul.no]
Sent: Thursday, July 10, 2003 1:15 AM
To: Tomcat Users List
Subject: RE: XML DOCTYPE problem


And i think it even has to have a http:// in front

-----Original Message-----
From: Abid Ali Teepo
Sent: 10. juli 2003 09:38
To: Tomcat Users List
Subject: RE: XML DOCTYPE problem


I think the reference to a doctype has to be on the format
www.somesite.com/dtd/data.dtd or similar

Besides i don't thinkt it will actually validate against that
DTD anyway ....

-----Original Message-----
From: Brian Menke [mailto:brian.menke@lspeed.com]
Sent: 10. juli 2003 07:21
To: Tomcat Users List
Subject: XML DOCTYPE problem


Hi everyone,

I have created a JSP page that use the jstl xml tag library, specifically
using
xpath. Everything works perfectly fine as long as I don't have a doctype
declaration like the following in my XML instance:

<!DOCTYPE datasheet PUBLIC "-//Innovtech//DTD datasheet//EN"
"c:/dtds/innovtech/datasheet.dtd">

If I remove it, everything works great, but if I don't, I get a java error
like this:

org.apache.jasper.JasperException: Could not resolve entity reference:
"///c:/dtds/innovtech/datasheet.dtd"

I have to have the doctype in the xml. Does anyone know how I can fix this??

I did post this to the taglib email list, but it doesn't seem to get near
the traffic as this group.

Thanks!

-Brian


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message