tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Pabst <simon.pa...@web.de>
Subject Re: which mod_jk.so to use with Apache 1.3
Date Thu, 17 Jul 2003 16:40:44 GMT
For Apache 1.3 you're better off with mod_jk1 since mod_jk2 requires APR 
libraries which aren't included with Apache 1.x.
Building those on Solaris is propably compiler hell ;-).

Download mod_jk 1 source here:
http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk/release/v1.2.4/src/jakarta-tomcat-connectors-jk-1.2.4-src.tar.gz

Build it:
(see 
http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/jk/aphowto.html#Building%20mod_jk%20on%20Unix

)

tar -zxf jakarta-tomcat-connectors-jk-1.2.4-src.tar.gz
cd jakarta-tomcat-connectors-jk-1.2.4-src/jk/native
sh buildconf.sh

#optional - set environment variable to use compiler optimizing (bash syntax)
export CFLAGS="-O2"

./configure --with-apxs=/path/to/apache/bin/apxs
#optional - needed for Apache with mod_ssl
--enable-EAPI

make
cp ./apache-1.3/mod_jk.so /path/to/apache/libexec/


At 12:24 17.07.2003 +0200, you wrote:
>Hi,
>
>I try to connect tomcat 4.1.24 to an existing Apache 1.3 installation 
>(Solaris 8).
>To do so I read I need mod_jk.so and I found a download page
>http://jakarta.apache.org/builds/jakarta-tomcat-connectors/jk2/release/v2.0.2/bin/solaris8/
>but below it says to get
>
>    * mod_jk2-1.3-eapi.so is for Apache 1.3.x with mod_ssl
>    * mod_jk2-1.3-noeapi.so is for Apache 1.3.x without mod_ssl
>
>and they are not listed above.
>Has anyone done sth. similar and can tell me what to use if my
>plans aren't impossible (due to old Apache version) at all?
>Thanks.
>Astrid
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message