tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Pb with webapp admin
Date Thu, 10 Jul 2003 14:57:51 GMT
At 08:22 AM 7/10/2003 +0200, you wrote:
>Hi,
>
>i use a tomcat 4.1.18 on a Linux RedHat 7.3
>All my directories "images" are a linux link in my webapp, so i have put 
>this on my server xml betwen the two tag "context"
>
><Resources className="org.apache.naming.resources.FileDirContext" 
>allowLinking="true"/>
>
>so it's work, but when i use the webapp admin in order to change some 
>other parameters and when i commit, tomcat delete the line of my 
>link....in my server.xml so i lost my images when he reboot...
>
>Do you know why ?

Put any <Context> specific stuff in a context configuration file.  See 
admin.xml and manager.xml in webapps for an example.  You must be using the 
manager app to upload a .war file since the server.xml is getting 
reloaded.  So, name your context configuration file "context.xml" and put 
it in the META-INF directory of your .war file.  Now do the upload and your 
context information should be there.

Jake



>thanks for your advice
>Yannick
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message