tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark W. Webb" <m...@dolphtech.com>
Subject help - problem loading classes on startup
Date Tue, 08 Jul 2003 17:49:26 GMT
If anyone could help me out, it would be greatly appreciated.  I have 
been working this issue for 2 weeks and cannot figure out what the 
problem is.  

Thank you.

Mark W. Webb wrote:

> I have wrote a C program that starts up tomcat using the Invocation 
> API.  The reason for this is so that I can prompt the user for a 
> password that will open up a PKCS12 file If anyone has a better 
> solution, please let me know).
>
> I have downloaded the tomcat 4.1.24, and commons-digester source and 
> am trying to figure out why I cannot get my program to work.  I have 
> traced the problem to the Digester code.  The Digeter class is having 
> a problem finding classes :
>
> org.apache.catalina.core.StandardServer
> org.apache.catalina.deploy.NamingResources
> org.apache.catalina.deploy.ContextEnvironment
>
> When I turn on debugging in tomcat, I get the following output :
>
> <snip>
> ClassLoaderFactory:    Including jar file 
> /tmp/jakarta-tomcat-4.1.24-src/build/server/lib/catalina.jar
> </snip>
>
> which is where org.apache.catalina.core.StandardServer is, so I am 
> confused.
>
> Although when I run tomcat in the standard way (startup.sh), all goes 
> well.
>
> Could someone please help
>
> Thank you.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message