tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerry Reno <gren...@yahoo.com>
Subject Re: Tomcat 5.0.3: Cannot get rid of webapp context either manually or with manager tool
Date Mon, 14 Jul 2003 16:57:21 GMT
Tim,
  Ok, I found that in conf/Catalina/ the subdirectories are the vhosts.
 In the vhost subdir I found a <context>.xml file for the ghost
context.  I removed this file and restarted Tomcat and the ghost
context disappeared.  Just to test I redropped the war file in the
vhost webapps dir.  The context appears under manager and everything
works.  I rechecked the vhost subdir under conf/Catalina/ but no
<context>.xml showed up.  Once I went into the admin app and committed
a change then the <context>.xml was created under conf/Catalina/.  It
would seem to me that the Undeploy command in the manager app should be
removing the <context>.xml file under conf/Catalina/<vhost>.  It is not
doing that.  Should this be filed as a bug?

Gerry Reno


--- Tim Funk <funkman@joedog.org> wrote:
> For a ultra clean sweep (i think) ...
> 
> - Stop tomcat.
> - Look for any directories in the webapps dir (or alternate defined
> by 
> server.xml)
> - Look in conf's sub-directories for xml files.
> - Look for any war files
> 
> You shouldn't need to do these 2 because these shouldn't happen
> (IIRC) ...
> - Look for any .xml files in the  webapps dir (or alternate defined
> by 
> server.xml) - then examine the contents
> - Take <Context> references out of server.xml
> 
> -Tim
> 
> Gerry Reno wrote:
> >   In one of my vhosts I have a webapp that was installed by
> dropping a
> > war into the appropriate directory for this vhost.  The webapp
> works
> > fine.  I subsequently wanted to remove this webapp for the vhost so
> I
> > went into the  vhost manager app and selected 'Undeploy' link.  It
> > responded with "FAIL - Cannot undeploy document base for path
> > /mywebapp".  So then I tried manually deleting the webapp by
> removing
> > the WAR file and directory and deleting the vhost tomcat work area.
> 
> > Restarted Tomcat and the webapp was still listed.  You could start
> it
> > but it didn't do anything when you tried to access the context.  I
> > tried clicking on 'Undeploy' again - no luck - same error message
> as
> > before.  So now I stuck.  This ghost of a context refuses to go
> away
> > even though I think I have removed every trace of it that I can
> find. 
> > Any suggestions?
> > 
> > thx,
> > Gerry Reno
> >  
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 


__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message