tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjay <sb6...@yahoo.com>
Subject RMI-IIOP on Tomcat
Date Tue, 08 Jul 2003 17:40:41 GMT
I am trying to set a RMI-IIOP server on Tomcat.
Getting some issues. 
MY RMI Server works fine if I start it standalone-
without Tomcat. I think have been able to set security
codebase etc correctly.

Environment : Tomcat 4.1, Win NT4, JDK1.4.1
I have issues when I start the RMIServer in Tomcat.
I can start tomcat in the secured mode and start my
RMI server successfully but then I run into two
different kinds of problems:

1. If I run the client from the same m/c as Tomcat
then I can do the lookup and also do the
PortableRemoteObject.narrow(). But a client on a
difffrent m/c (in the same LAN) can not execute the
narrow() - gives classcast Exception.

2. I can not execute a method on the server (even when
I get the narrow() to succeeed). Gives error:
java.rmi.NoSuchObjectException: CORBA OBJECT_NOT_EXIST
1398079692 No

Has anyone done this. Any ideas suggestions would be
welcome
Thanks
Sanjay




__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message