tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcio Merlone ...@surf.com.br>
Subject Help for a newbie - Unable to load class present
Date Mon, 07 Jul 2003 13:29:50 GMT
Hello all,

I am really sorry to ask this here, since it looks like a very dumb
question and probably could be found somewhere on the net, but I am
completely lost. I am a sys admin and trying to set up jamm
(jamm.sourceforge.net) to admin a postfix server with ldap-stored users.
The java components documentation is not much clear on how to install
its pieces, so I probably has lost something.

I am running a Jakarta-tomcat like this:

root@/usr/local> /usr/local/jakarta-tomcat-4.1.24/bin/startup.sh  
Using CATALINA_BASE:   /usr/local/jakarta-tomcat-4.1.24
Using CATALINA_HOME:   /usr/local/jakarta-tomcat-4.1.24
Using CATALINA_TMPDIR: /usr/local/jakarta-tomcat-4.1.24/temp
Using JAVA_HOME:       /usr/local/j2sdk1.4.2
root@/usr/local> 

The main tomcat page opens fine, hacked conf/tomcat-users.xml so admin
and manager pages are all OK. I downloaded jamm and untared on
/usr/local/jakarta-tomcat-4.1.24/webapps/ROOT/jamm-0.9.4

When I access the url

http://server:8080/jamm-0.9.4/index.jsp I get the error:

type Exception report
message
description The server encountered an internal error () that prevented
it from fulfilling this request.
exception
org.apache.jasper.JasperException: /jamm-0.9.4/index.jsp(0,5)
/jamm-0.9.4/WEB-INF/common/all_definitions.jsp(6,0) Unable to load class
present	at
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHan
dler.java:94)	at
org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.jav
a:428)	at
org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.jav
a:126)	at
org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:3
07)	at
org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:340)
at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:378)
(...)

Jamm requires:
    * Java JDK, version 1.3.x or 1.4.x
      http://java.sun.com/
    * XDoclet, version 1.1
      http://xdoclet.sourceforge.net/
    * Log4j, version 1.1.3
      http://jakarta.apache.org/log4j
    * Cryptix, version 3.2.0
      http://www.cryptix.org/
    * Servlet, vesion 2.3
      http://java.sun.com/products/servlet/
    * Checkstyle, version 2.2
      http://checkstyle.sourceforge.net/
    * Struts, version 1.1b3
      http://jakarta.apache.org/struts/index.html

I am probably missing something on those requirements, but I have no
idea on how to even start to track this down. Questions:

1. In general, what is the way to install some component on a servlet
server? Simply copy all *.jar files to (in my case)
/usr/local/jakarta-tomcat-4.1.24/common/lib ?

2 What are the relevant env variables to set? Actually I have:
CATALINA_HOME=/usr/local/jakarta-tomcat-4.1.24/
ANT_HOME=/usr/local/jakarta-ant-1.5
JAVA_HOME=/usr/local/j2sdk1.4.2
CLASSPATH=/usr/local/j2sdk1.4.2/lib/log4j-1.2.8.jar:/usr/local/junit3.8
.1/junit.jar:/usr/local/jakarta-tomcat-4.1.24/common/lib/servlet.jar

This machine is a Linux slackware 9 with kernel 2.4.21. Any help, point
to any doc, url is appreciated.

Regards,


-- 
Marcio Merlone

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message