tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Ewing <natew...@yahoo.com>
Subject Wierd Tomcat Problem
Date Tue, 01 Jul 2003 20:23:56 GMT
Attached is a demonstration application for my problem.  You will have to
include standard.jar for it to work because it wouldn't let me post to the list
with that file included (too big).

Just run apptest/main2 to see the problem.

Here is the description again:
------------------------------
Here is what I'm doing:

I created a servlet that forwards to a jsp.  Inside the jsp I put the 
line <%@
taglib prefix="c" uri="http://java.sun.com/jstl/core" %> (actually its 
in an
<%@ include %> file inside the jsp).  When I try to run the servlet I 
get the
following error:

org.apache.jasper.JasperException: /userForm.jsp(0,0) This absolute uri
(http://java.sun.com/jstl/core) cannot be resolved in either web.xml or 
the jar
files deployed with this application
	at
org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:94)
	at
org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:428)
	at
org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:126)
	at 
org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:307)
	at 
org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:340)
	at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:378)


It actually keeps going with a bunch more compiler items but I thought 
that was
enough.

Now if I remove all other servlets in my web.xml except this one, and 
then
rerun my servlet, everything works perfectly without the bug.

This means that every single time I make a change to a jsp, I have to 
go into
my web.xml, remove all other servlets, and then run my jsp.

What am I doing? or is this a bug in Tomcat.


       Thanks,
       Nathan Ewing

Mime
View raw message