tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Atreya Basu <atr...@greenfieldresearch.ca>
Subject RE: Tomcat4-1, Apache2, jk2 setup problem - help!
Date Fri, 18 Jul 2003 16:50:39 GMT
Okay,

Probably leaving the connector for 8080 un-commented won't hurt anything
while testing.  The fist thing you want to do is make sure your
environment variables are set.  You should have:
JAVA_HOME
CATALINA_HOME
APACHE_HOME
TOMCAT_HOME

Also can you post your jk2.properties and workers2.properties files?
And what are the directories for Tomcat, Apache2 and Java?



_____________________________________
Atreya Basu
Developer,
Greenfield Research Inc.
e-mail: atreya (at) greenfieldresearch (dot) ca

-----Original Message-----
From: Tricky [mailto:tricky@mac.com] 
Sent: July 18, 2003 12:57 PM
To: 'Tomcat Users List'
Subject: RE: Tomcat4-1, Apache2, jk2 setup problem - help!

Yes, I just have to uncomment the standalone section in server.xml, and
I can then access tomcat on http://localhost:8080. However, I really
need the two working in unison!

Cheers,

Tristan

-----Original Message-----
From: Atreya Basu [mailto:atreya@greenfieldresearch.ca] 
Sent: 18 July 2003 16:08
To: 'Tomcat Users List'
Subject: RE: Tomcat4-1, Apache2, jk2 setup problem - help!

Tristan,

Can you start Tomcat on its own?  

_____________________________________
Atreya Basu
Developer,
Greenfield Research Inc.
e-mail: atreya (at) greenfieldresearch (dot) ca

-----Original Message-----
From: Tristan [mailto:tristan@intensiv.net] 
Sent: July 17, 2003 12:21 PM
To: tomcat-user@jakarta.apache.org
Subject: Tomcat4-1, Apache2, jk2 setup problem - help!

Hi,

I'm trying to install tomcat 4.1 on my win XP machine using Apache 2 and
jk2. However, I seem to be encountering some difficulties.

The problem is, I can't seem to get tomcat to start as a service when I
request a url (e.g. http://localhost/examples), it simply returns.

***
The servlet container is temporary unavailable or being upgraded 
Internal Server Error

--snip apache babble--

Apache/2.0.47 (Win32) PHP/4.3.2 mod_jk2/2.0.2 Server at localhost Port
80
***

I noticed that starting Tomcat seems to throw some kind of java error,
but it closes the window too quickly for me to repeat exactly what it
reports. However, when I comment out the line

	channelJni.disabled = 0

in my jk2.properties file, I can start tomcat standalone, and access the
examples etc through apache.

Can anyone tell me why I can not start tomcat as a process through
apache? I followed a how-to at:
http://www.gregoire.org/howto/Apache2_Jk2_TC4.1.x_JSDK1.4.x.html

And believe I have made sure I have followed the instructions very
closely. Any help is very much appreciated.

Cheers,

Tristan




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message