Hi all

 

I’m using log4j in two webapps, which means I’ve copied the log4j.jar into both WEB-INF/lib directory for each webapp. I’m loading a log4j.xml for configuration from my webapp and this works great when I run the app from the command line using the tomcat startup scripts. I can vary the settings in each log4j.xml and see the effect shortly afterwards in my logs for that webapp.

 

However, when I run tomcat under a debugger (ide) like Eclipse the behaviour is different. The logs work OK but if I modify one log4j.xml it affect BOTH webapps. It’s like as if the classloader in tomcat is sharing the log4j.jar file?

 

Anybody have any idea why this would happen under an IDE? It was also observed under Visual Café Expert edition so it’s not just an Eclipse problem.

 

I’m using Tomcat 4.1.18 and JDK 1.4.1_02-b06 but we’ve noticed this same problem with older tomcat’s and JDK’s.

 

Thanks for any help

Donie

 



**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the sender.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.

**********************************************************************