tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abid Ali Teepo" <>
Subject Connector will not redirect to HTTPS
Date Mon, 30 Jun 2003 14:58:48 GMT

Somehow tomcat will not redirect requests to pages under a security constraint to https.
Instead i get an "HTTP 500 Internal Server Error"

In my server.xml the two connectors look like this :

<!-- Define a non-SSL Coyote HTTP/1.1 Connector on port 8081 -->
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8080" minProcessors="5"
maxProcessors="75" enableLookups="true" redirectPort="8443" acceptCount="100" debug="0" connectionTimeout="20000"
useURIValidationHack="false" disableUploadTimeout="true" />
<!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8443" minProcessors="5"
maxProcessors="75" enableLookups="true" acceptCount="100" debug="0" scheme="https" secure="true"
useURIValidationHack="false" disableUploadTimeout="true">
<Factory className="org.apache.coyote.tomcat4.CoyoteServerSocketFactory" clientAuth="false"
protocol="TLS" />

And my security constraint looks like this in the web.xml file :
  			<web-resource-name>Secure Zone</web-resource-name> 

And even though i get the HTTP 500 error the server will not redirect to my error
page that i have define like this :


Please help


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message