tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Januski, Ken" <kjanu...@phillynews.com>
Subject Connectors for IIS/Tomcat SHOULD make sense
Date Mon, 23 Jun 2003 17:19:12 GMT
but I've yet found any sensible explanation of hooking up IIS and Tomcat. I
have found step by step instructions but not any explanations. What's more
embarrassing is that I posted a similar IIS/Tomcat problem 3-4 months ago,
finally solved it, and now I've upgraded Tomcat and have it again.

Though there are a number of howtos on getting IIS and Tomcat working
together I'm still looking for some help in making sense of the actual
process, in other words I ought to be able to look at the redirector logs
and figure out what the problem is, or at least where to start looking. The
redirector logs seem to be full of useful information and yet I see numerous
people posting messages here asking for help with them. So I guess what I'm
asking is if there is any resource that can help explain the logs. I'd
really like to just read them and diagnose the problem based on that. Can
anyone point me to such a resource?

I believe that my current problem is that Tomcat is trying to map the
redirector when it should be doing something else. So I'm getting log
entries that say:

[jk_isapi_plugin.c (759)]: In HttpFilterProc Virtual Host redirection of
/inqtomcat/jakarta/isapi_redirector.dll
[jk_uri_worker_map.c (460)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (477)]: Attempting to map URI
'/inqtomcat/jakarta/isapi_redirector.dll'
[jk_uri_worker_map.c (599)]: jk_uri_worker_map_t::map_uri_to_worker, done
without a match
[jk_isapi_plugin.c (765)]: In HttpFilterProc test Default redirection of
/jakarta/isapi_redirector.dll
[jk_uri_worker_map.c (460)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (477)]: Attempting to map URI
'/jakarta/isapi_redirector.dll'
[jk_uri_worker_map.c (599)]: jk_uri_worker_map_t::map_uri_to_worker, done
without a match

I'm pretty sure that Tomcat shouldn't be trying to map the dll though that's
just a guess. That's why I believe that if I could find some explanation of
the whole process I could figure out the answer on my own, and perhaps
others could as well, rather than sending so many message here regarding it.

By the way I have looked at archives and seen a number of entries that come
close to solving the above problem. But none of them work for me and they
don't really explain what is going on, or if they do I'm just missing it. As
I said I think if I could figure out what is going on in the connector
process that I could figure it out for myself.

Thanks for any help.

Ken



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message