tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Euan Guttridge <EGuttri...@buildonline.com>
Subject RE: ClassNotFoundException
Date Mon, 16 Jun 2003 15:14:35 GMT
Check if your MySql driver requires an LD_LIBRARY_PATH addition (and is
accessible to the tomcat shell). We had the same error and issue with Oracle
thick client and tomcat on Linux.

-----Original Message-----
From: Guus Holshuijsen [mailto:guus.holshuijsen@videtur.nl] 
Sent: 16 June 2003 14:06
To: tomcat-user@jakarta.apache.org
Subject: ClassNotFoundException


Hi!

I checked the mailing archive and found some mail but never any answers.
Here goes....

I use the following software:
+ Tomcat 4.1.24 or Tomcat 4.0.6 
+ mysql-connector-java-3.0.8-stable-bin.jar (in the 
+ $CATALINE_HOME/common/lib) MySQL database server 3.23.51 my own web 
+ application below $CATALINE_HOME/webapps

The web application I created writes a blob to the MySQL database (there is
no problem here). When the web application tries to read the blob from the
database a ClassNotFoundException is thrown in the
com.mysql.jdbc.ResultSet.getObject method while "wading" the object input
stream.

I tried different versions of the mysql driver software (org.gjt.mm.mysql
package) .... I tried different versions of Tomcat .... I tried what Sriram
Narayanan writes in his message of 21 feb 2002 (put the mysql jar not only
in the $CATALINE/common/lib directory but also in the
$CATALINA_HOME/webapps/<webapp name>/WEB-INF/classes/lib directory) ..... I
tried using the Tomcat DataSource resources .....

All to no avail!

Is there anybody who has any ideas .......?

Regards,
Guus


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message