tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: Tomcat 4.1.24/Win2K - Servlet not found.
Date Wed, 25 Jun 2003 16:54:41 GMT

Howdy,

>But if I have http://localhost:8080/myApp/servlet/TestingServlet,
(without
>the web.xml file)     it doesn't find the servlet.
<snip>

Add to your web.xml:
<servlet-mapping>
  <servlet-name>Testing</servlet-name>
  <url-pattern>/servlet/TestingServlet</url-pattern>
</servlet-mapping>

And then the above URL will work.

>also, I'm learning from a book am not sure what the use of <web-app>
tag
>is, in the web.xml file?

It's simply the root tag in the schema.  It is required (and you cannot
have more than one) for the web.xml file to be valid.

Yoav Shapira



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message