tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hertenstein Alain <>
Subject RE : IIS 5 + Tomcat 4.1.24 + JK2 Connector problem
Date Wed, 25 Jun 2003 14:31:37 GMT
Hi David,

No I don't have any, here is what I have in my file :

#Define the communication channel
info=Ajp13 forwarding over socket

# Map the Tomcat examples webapp to the Web server uri space
info=Map the whole webapp

What is that [shm] entry you mentioned ?

Thanks again,

-----Message d'origine-----
De : David Legg [] 
Envoyé : mercredi, 25. juin 2003 16:23
À : 'Tomcat Users List'
Objet : RE: IIS 5 + Tomcat 4.1.24 + JK2 Connector problem

Do you have an entry for [shm] in your file?  It is
essential that it is present for the JK2 connector to work correctly.  This
didn't appear in any documentation I found.

Most of the error messages you mention are there even in working
configurations so don't worry about them.


David Legg
Webmaster - 3Dlabs
Phone: +44 (0)118 982 8254

-----Original Message-----
From: Hertenstein Alain []
Sent: 25 June 2003 14:45
To: 'Tomcat Users List'
Subject: IIS 5 + Tomcat 4.1.24 + JK2 Connector problem

Hi everybody,

Seems like this problem is quite known, so I hope you can help me (after
searching the web and reading Apache docs, I can't figure it out) :

I've installed IIS, JDK 1.4.1_01 and Tomcat 4.1.24 on a Win2k Server
computer : everything works fine, all pages work (http://localhost for IIS
and http://localhost:8080 for Tomcat, as well as the JSP and Servlets
examples). After that I followed the instructions on the jakarta web site to
install the JK2 connector : after some trials (and some typo errors from my
side in the Registry...), I finally got that green arrow in the IIS Console
regarding the isapi_redirector2.dll ! Seems everything was working fine,

1) the http://localhost/examples/ page doesn't show up (web error page
2) in the Event Log, the following error entries appear each time I try to
access the upper URL :

Error: [jk_worker_lb.c (192)]: lb.getWorker() reenable ajp13:localhost:8009
 rror: [jk_endpoint.c (90)]: workerEnv.init() create slot epStat.0 failed

Error: [jk_worker_lb.c (402)]: lb.service() worker failed 120000 for

Error: [jk_worker_lb.c (415)]: lb.service() unrecoverable error...

I don't know what to do, I think all configuration is correct but still it
doesn't work.

Can anyone help me please ? Thanks a lot

To unsubscribe, e-mail:
For additional commands, e-mail:

 This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message