tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cosmin" <>
Subject Nightmare with Tomcat 4.1 and SSL configuration
Date Tue, 03 Jun 2003 21:22:15 GMT
Hi there ,
I've just registered to this list in hope that I could find some better
advice here . I am trying to configure a standalone installation of tomcat
to work with SSL . This at first doesn't seem like a bit headache . I have
followed the two similar howtos at the sun website and jakarta website and
have gotten the same result .

The only wierd thing about setting it all up was using keytool . I am
using a FreeBSD 4.8 machine with Tomcat 4.1 and linux-jdk1.4 . At first
the linux-jdk1.4 keytool didn't seem to work ( telling me that /dev/random
has reached the end of file ... i looked and this was a blank file ) . So
I generated they key using the FreeBSD jdk1.4 ( suposedly of alpha quality
) , exported it to a file then imported this file into a new keystore :
/root/.keystore using the linux-jdk1.4/bin/keytool .

I then added the following to my server.xml :

<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
               port="8443" minProcessors="5" maxProcessors="75"
	       acceptCount="100" debug="0" scheme="https" secure="true"
               useURIValidationHack="false" disableUploadTimeout="true">
               clientAuth="false" protocol="TLS"

Tried restarting . As I was watching with netstat the 8180 port opened for
a split second then closed . Tomcat seems to die the moment i try to start
it with the ssl connector uncommented . The moment i put comments arround
the SSL connector Tomcat starts up and works fine again . . .

Has anybody here , ever encountered this miserable problem ? I've been
stuck on it for 2 days and I don't even get an error message to start from
somewhere . no error logs are... WOOPS :) ... found a very relevant error

Exception during startup processing
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.lang.reflect.Method.invoke(
        at org.apache.catalina.startup.Bootstrap.main(
Caused by: java.lang.InternalError: URLSeedGenerator file:/dev/random
reached end of file
and it goes on

so that /dev/random file is creating trouble here . Does anybody here have
a clue on how to fix this ?

thanks in advance


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message