tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hartmut Bernecker <h.bernec...@dhw.de>
Subject ISAPI integration: Tomcat 4.1.24, IIS 5 with HTTP PUT request
Date Thu, 26 Jun 2003 07:40:14 GMT
Hello,

I am faced to the problem that the Tomcat-IIS integration doesn't work when doing some HTTP
PUT Request!
HTTP GET and HTTP POST requests works well.
Also HTTP PUT Request works well when running Tomcat standalone (w/o IIS, Port 8080).

You have some Idea? I do not.

Hartmut Bernecker



THE REQUEST:

PUT /asim/savexml?hierid=12 HTTP/1.1
Content-Type: text/xml
User-Agent: XMLSpyDocEditPlugIn
Host: ep158:9999
Content-Length: 943
Connection: Keep-Alive
Cache-Control: no-cache
Cookie: JSESSIONID=9A85D9E5B0796C0C309DBC3EB207235F

<?xml version="1.0" encoding="UTF-8"?>
<af-longtext>
	[... some xml data ...]
</af-longtext>

THE RESPONSE:

HTTP/1.1 500 Server Error
Server: Microsoft-IIS/5.0
Date: Wed, 25 Jun 2003 14:06:05 GMT
Connection: close
Content-Type: text/html
Content-Length: 79

<html><head><title>Error</title></head><body>Falscher
Parameter. </body></html>

THE ISAPI-LOG:

[Wed Jun 25 16:02:16 2003]  [jk_ajp_common.c (1318)]: Error connecting to tomcat. Tomcat is
probably not started or is listening on the wrong port. Failed errno = 61
[Wed Jun 25 16:02:16 2003]  [jk_isapi_plugin.c (928)]: HttpExtensionProc error, service()
failed

WORKERS PROPERTIES:

worker.list=testWorker
worker.testWorker.port=8009
worker.testWorker.host=localhost
worker.testWorker.type=ajp13

URIWORKERMAP PROPERTIES:

/myApp/*=testWorker





---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message