tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Zellhoefer <da...@8bit-inferno.de>
Subject Re: easy question
Date Tue, 24 Jun 2003 10:36:25 GMT
Thank you all! My problem was something in between the "developer's ide 
knows all packages" and the fact that I was presuming that the JSP and 
my class are within the same package.
Thanks for the tip about the JAR, I'll use this. It's very convenient.
Cheers,

David

Holger Klawitter wrote:
> Am Dienstag, 24. Juni 2003 11:28 schrieb David Zellhoefer:
> 
>>Hello!
>>
>>I have a easy question for you:
>>
>>1)I have written a class called Test, compiled it and placed it in
>>~/WEB-INF/classes/
>>2) Now I want to use objects from Test in a JSP, but if I try to use
>>Test Tomcat always tells me that it is not able to resolve the symbol.
>>
>>What shall I do? Do I need to change the web.xml?
> 
> 
> the contents of "classes" is not part of any package, whereas your jsp page 
> is. You have to "import" your class.
> 
> Mit freundlichem Gruß / With kind regards
> 	Holger Klawitter
> --
> lists@klawitter.de
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message