tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Fiol BonnĂ­n <fiol.bon...@terra.es>
Subject Re: unable to start tomcat4.1.24
Date Tue, 17 Jun 2003 07:27:58 GMT
Paridhi Bansal wrote:

>hi all!
>
>i was earlier using tomcat4.0.6...because of better performance and stability in 4.1.24,
i am planning to upgrade to tomcat4.1.24...but on installing that from *.zip file , when i
try to run startup.sh, it give me the error
>The JAVA_HOME environment variable is not defined correctly
>This environment variable is needed to run this program
>
>My JAVA_HOME variable is same as it was in tomcat4.0.6 and that was working very fine..i
tried removing 4.1.24 and reinstalling 4.0.6.It works fine then..What can be the problem???
>  
>

I don't know 4.0.6, but please make sure that your JAVA_HOME is defined

echo $JAVA_HOME

should output a directory name.

Make sure it exists, and contains a JDK. I believe that a JRE is not enough.

If it is not set, you can do (on bash):

export JAVA_HOME=/right/path/to/your/j2sdk1.4/

And then you launch startup.sh as usual.

Antonio Fiol

Mime
View raw message