tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Bainbridge <ja...@jblinux.org>
Subject Re: Connectors for IIS/Tomcat SHOULD make sense
Date Wed, 25 Jun 2003 19:45:52 GMT
Any idea why it is trying to map the below? 

'/inqtomcat/jakarta/isapi_redirector.dll'

Have you got your IIS setup like that? If you do it has to be:

'/jakarta/isapi_redirector.dll'

I just re-read your original email over and over, whilst scanning through the 
source and that jumped out at me, it could be nothing and is validly 
including your host name but it's worth checking out atleast...

Regards,
Jason

On Thu, 26 Jun 2003 02:41, Januski, Ken wrote:
> Windows Registry Editor Version 5.00
>
> [HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation]
>
> [HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
> Redirector]
>
> [HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
> Redirector\1.0]
> "extension_uri"="/jakarta/isapi_redirector.dll"
> "log_file"="C:\\\\Tomcat4112\\\\logs\\\\isapi.log"
> "log_level"="debug"
> "worker_file"="C:/Tomcat4112/conf/workers.properties"
> "worker_mount_file"="C:/Tomcat4112/conf/uriworkermap.properties"
> @=""
>
>
> -----Original Message-----
> From: Jason Bainbridge [mailto:jason@jblinux.org]
> Sent: Wednesday, June 25, 2003 2:36 PM
> To: Tomcat Users List
> Subject: Re: Connectors for IIS/Tomcat SHOULD make sense
>
>
> Just for a sanity check can you export your registry settings for the below
> key and send them to the list?
>
> HKEY_LOCAL_MACHINE
>    SOFTWARE
>      Apache Software Foundation
>          Jakarta Isapi Redirector
>            1.0
>
> Regards,
> Jason
>
> On Thu, 26 Jun 2003 02:23, Januski, Ken wrote:
> > Some progress...............................
> >
> > I haven't spent much time looking at the IIS logs but rather at the
> > isapi_redirect logs. But today I did and happened to notice that the old
> > logs for Tomcat before I upgraded and things stopped working has this
> > when it redirects to Tomcat:
> >
> > GET /jakarta/isapi_redirector.dll - 200 Java1.4.0_01
> >
> > The new logs where it's failing show this instead:
> >
> > GET /jakarta/isapi_redirector.dll - 200
> > Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.0)
> >
> > Both show 200 to indicate that they're forwarding successfully I think.
>
> But
>
> > the successful one seems to link to Java and the unsuccessful to the
> > browser. Once I get that figured out I'm hoping problem may be solved.
> >
> >
> >
> >
> > -----Original Message-----
> > From: Januski, Ken [mailto:kjanuski@phillynews.com]
> > Sent: Tuesday, June 24, 2003 6:09 PM
> > To: Tomcat Users List
> > Subject: RE: Connectors for IIS/Tomcat SHOULD make sense
> >
> >
> > Thanks Jason,
> >
> > Yes I've edited the registry over and over, trying forward slashes,
> > backslashed backwards slashes, etc. in path name all to know avail. I'm
> > going to call it quits for today and hope that something will make more
> > sense tomorrow. If not I guess I'll just start from scratch with a
> > reinstallation.
> >
> > The fact the the redirect logs say that they've found so many rules and
> > then found matches against those rules makes me think that there is no
> > problem finding the uriworkermap.properties files, since that's where
>
> these
>
> > are defined. But something sure is whacky with the loading of
> > isapi_redirect(or). Maybe tomorrow it will all make more sense.
> >
> > Thanks much for all your efforts in trying to solve it.
> >
> > Ken
> >
> > -----Original Message-----
> > From: Jason Bainbridge [mailto:jason@jblinux.org]
> > Sent: Tuesday, June 24, 2003 5:21 PM
> > To: Tomcat Users List
> > Subject: Re: Connectors for IIS/Tomcat SHOULD make sense
> >
> > On Wed, 25 Jun 2003 04:53, Januski, Ken wrote:
> > > I've honed uriworkermap.properties down to just this simple one below
>
> and
>
> > > have only tried accessing pages that it should find, like
> > > http://inqtomcat/examples/jsp/index.html
> >
> > I'm taking a guess here that it isn't finding your
> > uriworkermap.properties file and it is trying to load everything
> > including the DLL (which
>
> obviously
>
> > should be loaded by IIS).
> >
> > Have you got all the registry keys setup correctly as per the following
> > page?
> >
> > http://www.onjava.com/pub/a/onjava/2002/12/18/tomcat.html?page=2
> >
> > Regards,

-- 
Jason Bainbridge
http://jblinux.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message