tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From john d barreto <jbarr...@cs.fiu.edu>
Subject Problem installing Apache-SOAP on Tomcat 4.1.24 using Java 1.4.1_02
Date Sun, 29 Jun 2003 18:20:18 GMT
Hi Everybody,

I'm trying to get SOAP working on Tomcat 4.1.24.  I have j2se 1.4.1
installed on my Win98 machine.  Has anyone ever tried this?

When I launch "http://localhost/soap/servlet/rpcrouter" (I've changed the
default port to port 80 instead of port 8080), I get the following
message:
javax.servlet.ServletException: Error allocating a servlet instance
at
org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:672)
..
.
root cause
java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet
at java.lang.ClassLoader.findBootstrapClass(Native Method)
..
.

If I try to list the deployed services I get:
org.apache.jasper.JasperException: javax/servlet/ServletContext
.
root cause
javax.servlet.ServletException: javax/servlet/ServletContext
.

I have no idea how to fix this.  I don't know if it has to do with the new
sdk1.4.1's "endorsed directories".  The instructions for setting up Apache
Axis mention this :
http://cvs.apache.org/viewcvs.cgi/~checkout~/xml-axis/java/docs/install.html
(look under Step 2).
It is also described by Sun :
http://java.sun.com/j2se/1.4.2/docs/guide/standards/

Thanks,
J
P.S.  I don't want to work with Apache Axis.



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message