tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <ku...@inwind.it>
Subject TomCat configuration
Date Mon, 16 Jun 2003 18:06:45 GMT
Hello,

i'm using TomCat Standalone, and i have this little problem:

When i acces through a browser the site 'www.mysite.com', i will be served
by a servlet.
But now i cannot access no more to URLs like this: www.mysite.com/file.html:
in fact i will be always served directly by the servlet, and i will not get
back the html file i requested.

Any help?

Thanks in advance.
Luca

Here below my config files:
Web.xml:
===================
<web-app>
 <servlet>
  <servlet-name>S1</servlet-name>
 </servlet>

 <servlet-mapping>
  <servlet-name>default</servlet-name>
  <url-pattern>/*.html</url-pattern>
 </servlet-mapping>

 <servlet-mapping>
  <servlet-name>S1</servlet-name>
  <url-pattern>/</url-pattern>
 </servlet-mapping>
</web-app>
===================

conf/Server.xml
===============
<Host name="www.mysite.com" debug="0" appBase="c:\path\to\external\webapp\"
       unpackWARs="true" autoDeploy="true">
        <Context path=""
          docBase=""
          crossContext="false"
          debug="0"
          reloadable="true">
        </Context>
===============



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message