tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas, Kevin" <KEVIN.THO...@saic.com>
Subject RE: Question regarding "tomcat-apache.conf" file.
Date Mon, 16 Jun 2003 15:10:37 GMT
Actually, I don't have it installed as root at all, no permissions to do so,
it's a long story involving politics and it's only a dev box.  :O)

-----Original Message-----
From: John Turner [mailto:tomcat-user@johnturner.com]
Sent: 16 June 2003 16:01
To: Tomcat Users List
Subject: Re: Question regarding "tomcat-apache.conf" file.



Well, I think you may be stuck.  Your last error is regarding 
libpthread.so, which is not Tomcat related, or even Apache/Mod_JK related.

You can looking for libpthread.so* and symlinking whatever you find to the 
file that the error message mentions.

I'm curious, though...you want to run Apache, that means you have root 
access (generally).  How can you not also build things from source or 
otherwise access pkgadd?

John

On Mon, 16 Jun 2003 07:52:09 -0700, Thomas, Kevin <KEVIN.THOMAS@saic.com> 
wrote:

> LOL...you've probably already anticipated the answer to the first
> question...No, I'm afraid I can't build from source.
>
> 1.3.26 came from apache.org. I don't have access to pkgadd so 1.3.27 from
> sunfreeware is not an option (I don't think).
>
>
>
> -----Original Message-----
> From: John Turner [mailto:tomcat-user@johnturner.com]
> Sent: 16 June 2003 15:32
> To: Tomcat Users List
> Subject: Re: Question regarding "tomcat-apache.conf" file.
>
>
>
> Can you build things from source?  Does your Solaris box have all of the 
> latest patches?
>
> Where did you get 1.3.26?  There's a 1.3.27 at http://www.sunfreeware.com 
> for Solaris 2.6.
>
> John
>
> On Mon, 16 Jun 2003 07:25:51 -0700, Thomas, Kevin <KEVIN.THOMAS@saic.com> 
> wrote:
>
>> Latest issue is:
>>
>> ld.so.1:
>> /ki-sun4k2/export/home/apt2/ta_web/webserver/apache_1.3.26/bin/httpd: 
>> fatal:
>> libpthread.so.1: version `SUNW_1.2' not found (required by file
>> /ki-sun4k2/export/home/apt2/ta_web/webserver/apache_1.3.26/bin/httpd)
>> Killed
>> bin/apachectl start: httpd could not be started
>>
>> After installing Apache 1.3.26. Using mod_jk-1.3-noeapi.so
>>
>> K.
>>
>> -----Original Message-----
>> From: John Turner [mailto:tomcat-user@johnturner.com]
>> Sent: 16 June 2003 15:02
>> To: Tomcat Users List
>> Subject: Re: Question regarding "tomcat-apache.conf" file.
>>
>>
>>
>> Can you tell us what platform you're using?  Can you confirm exactly 
>> what Apache version you have?
>>
>> JK and JK2 are Apache version sensitive.  You could easily spend many 
>> hours trying various binary files without results because of 
>> incompatibilities.  If you tell us what you need, we can help you 
>> faster.
>>
>> Regarding the error message, does your Apache include mod_dir?
>>
>> John
>>
>> On Mon, 16 Jun 2003 06:41:24 -0700, Thomas, Kevin 
>> <KEVIN.THOMAS@saic.com> wrote:
>>
>>> Hmm, got this error while using mod_jk-1.2.2.so
>>>
>>> Syntax error on line 233 of
>>> /ki- 
>>> sun4k2/export/home/apt2/ta_web/webserver/apache_1.3.6/conf/httpd.conf:
>>> Cannot load
>>> /ki- 
>>> sun4k2/export/home/apt2/ta_web/webserver/apache_1.3.6/libexec/mod_jk- 
>>> 1.2
>>> .2.so into server: ld.so.1:
>>> /ki-sun4k2/export/home/apt2/ta_web/webserver/apache_1.3.6/bin/httpd: 
>>> fatal:
>>> relocation error: file
>>> /ki- 
>>> sun4k2/export/home/apt2/ta_web/webserver/apache_1.3.6/libexec/mod_jk- 
>>> 1.2
>>> .2.so: symbol dir_module: referenced symbol not found
>>> bin/apachectl start: httpd could not be started
>>>
>>>
>>>
>>> -----Original Message-----
>>> From: stephan beal [mailto:stephan@einsurance.de]
>>> Sent: 16 June 2003 14:20
>>> To: Tomcat Users List
>>> Subject: Re: Question regarding "tomcat-apache.conf" file.
>>>
>>>
>>> On Monday 16 June 2003 14:56, John Turner wrote:
>>>> No, its saying that the wrong (incompatible) .so file is being used.
>>>>
>>>> Apache 1.3.6 is ancient...I doubt any of the JK sources will work
>>>> with it, and there have been 21 revisions to the 1.3 source since
>>>> (currently at 1.3.27).  If "1.3.6" isn't a typo, you should first and
>>>> foremost upgrade your Apache.  If you can't upgrade for some reason,
>>>> you will have to build your own mod_jk from source, and my guess is
>>>> it won't be easy.
>>>
>>> i'm using Apache 1.3.x (.27 at the moment), and never had any problems 
>>> building mod_jk until ~1.2.3pre. Eventually i was able to build that 
>>> and 1.2.4, but had to jump through some hoops to do so.
>>>
>>> In the hope that they may save someone some effort, i've posted some 
>>> mod_jk bins for Solaris 8:
>>>
>>> http://stephan.rootonfire.org/mod_jk/
>>>
>>> a few moments ago i added a 1.2.2 and a 1.2.3pre-ish version.
>>> These bins are only known to work with Apache 1.3.27.
>>>
>>>
>>
>>
>>
>
>
>



-- 
Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message