tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guus Holshuijsen" <guus.holshuij...@videtur.nl>
Subject ClassNotFoundException
Date Mon, 16 Jun 2003 13:05:39 GMT
Hi!

I checked the mailing archive and found some mail but never any answers. Here goes....

I use the following software:
+ Tomcat 4.1.24 or Tomcat 4.0.6
+ mysql-connector-java-3.0.8-stable-bin.jar (in the $CATALINE_HOME/common/lib)
+ MySQL database server 3.23.51
+ my own web application below $CATALINE_HOME/webapps

The web application I created writes a blob to the MySQL database (there is no problem here).
When the web application tries to read the blob from the database a ClassNotFoundException
is thrown in the com.mysql.jdbc.ResultSet.getObject method while "wading" the object input
stream.

I tried different versions of the mysql driver software (org.gjt.mm.mysql package) ....
I tried different versions of Tomcat ....
I tried what Sriram Narayanan writes in his message of 21 feb 2002 (put the mysql jar not
only in the $CATALINE/common/lib directory but also in the $CATALINA_HOME/webapps/<webapp
name>/WEB-INF/classes/lib directory) .....
I tried using the Tomcat DataSource resources .....

All to no avail!

Is there anybody who has any ideas .......?

Regards,
Guus


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message