tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul \(BRI\)" <phish...@briconsultingroup.com>
Subject RE: Tomcat problems every morning.
Date Mon, 02 Jun 2003 02:32:47 GMT
My comment won't be that helpful - but I started out at the same place -
each morning I came in a got a call from staff saying the pages with
content pulled from the dbase was down. 

One thing I know, as others suggested, it has to do with the
JDBC/connection - in our case it happens when the network connection
between our linux box and our sql box os broken at some point - I think
the ISP does late night maintenance on the line (this is setup on an
office DSL line). We are still working to isolate the problem - but it
does seem to be JDBC related. I have tried simply pulling the cable on
the back of one box for a few seconds and the connection does die and
will not reconnect.

I plan to post back to the group when we get a better sense of the
problem - we are still fooling with it. In our case we are using MSSQL
with the MS JDBC driver. I thought I saw a post somewhere that said the
mySQL driver had a autoReconnect=true setting - I think I saw it on the
Apache site.

I hope you figure things out.

Paul

-----Original Message-----
From: Hollerman Geralyn M [mailto:gmh2441@louisiana.edu] 
Sent: Sunday, June 01, 2003 9:07 PM
To: Tomcat Users List
Subject: Re: Tomcat problems every morning.


On Sun, 01 Jun 2003 18:14:05 -0700, Hemendra Rana wrote
> Are you using mysql database on the backend too. Someone here
> pointed out that by default, mysql driver times out after every 8 
> hours. I still needs to verify whether that is the cause of my 
> problem though. Will let you know of my finds.

Why, yes, I am. And I thought perhaps MySQL was the problem - but I was
told by some people using Oracle and PostgreSQL databases that they'd
seen the problem as well. I tried putting in some code to set the driver
time-out value, but evidently I didn't do it correctly, as the problem
persisted. I don't see the error with versions of Tomcat previous to
4.1.x, tho.

Lynn Hollerman.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message