tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Ahten <pi...@pixelfreak.net>
Subject RPM for Tomcat 4.1.24 and JDK 1.4
Date Fri, 30 May 2003 16:12:12 GMT
Hello everyone,

I'm trying to install the "light" version of Tomcat 4.1.24 on Redhat 
Linux 7.3 from the RPM on the Jakarta site, but It fails due to the 
following dependencies.

java_parser_impl
xml-commons-apis
I have already installed the Java 1.4 JDK RPM from the Sun website....

J2sdk-1_4_1_02-fcs-linux-i586.rpm

Being new to Linux, I'm unsure where to find these additional packages 
and have the following questions about RPMs in general.

01. When a dependency is listed, is it linked to a particular RPM file 
or can any RPM that installs the same components work? I imagine 
multiple RPMs can be used, since projects like Tomcat are split up into 
multiple RPM files to allow updating individual components.

02. If so, how do I know which RPM file fulfills a particular 
dependency, such as javap_parser_impl? I haven't had much success 
searching for RPMs that have the characters javap_parser_impl in it's 
name. Also, can a single RPM provide support for more than one 
dependency?

Sites like http://www.jpackage.org/ and http://rpmfind.net list many 
packages, but do not specify which dependency they resolve.

Thanks,

~Scott


  


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message