tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chong Yu Meng <chon...@cymulacrum.net>
Subject Re: cant build jkjni.so
Date Sat, 24 May 2003 17:11:04 GMT
Hi Rick !

See if you can find the file libapr-0.so.0.9.3 inside /usr/lib/. This is 
the file it wants (apr = Apache Portable Runtime). Red Hat names it 
differently, and you may want to create a symbolic link to 
/usr/lib/libapr.so.0

I'm using RH8 + Apache 2 + mod_jk2 (rpm)

Regards,
pascal chong



Rick Roberts wrote:

> I'm getting an error when I try to build the connectors.
> mod_jk2.so build ok... i think, but not jkjni.so
>
> I'm using jakarta-tomcat-connectors-jk2-2.0.2-src
> I'm on Redhat 9 and using Apache2 (httpd-2.0.45) and Tomcat4 
> (tomcat4-4.1.24-full.2jpp)
>
> Apache is build from source, Tomcat4 is the RPM package.
>
>
> This is the ./configure command I use:
>
> ./configure --with-apxs2=/usr/local/apache2/bin/apxs \
>       --with-tomcat41=/var/tomcat4 \
>       --with-java-home=/usr/java/jdk1.4 \
>       --with-jni \
>       --with-pcre
>
>
> This is the error that I get:
>
> building connector for "apache-2.0"
> checking for tomcat33 location... not provided
> checking for tomcat40 location... not provided
> checking for tomcat41 location... /var/tomcat4
> checking for JDK location (please wait)... /usr/java/jdk1.4
> checking Java platform... checking Java platform...
> checking os_type directory...  linux
> configure: error: Apache 1.3 need apr to use jni
>
>
> What do I need to do to get apr?
> Why does error reference Apache 1.3 when it knows that I am building 
> connector for "apache-2.0" ??
>
> Thanks,
>



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message